Bug 10853 - HTML5 lacks a verbose description mechanism
HTML5 lacks a verbose description mechanism
Status: CLOSED WONTFIX
Product: HTML WG
Classification: Unclassified
Component: pre-LC1 HTML5 spec (editor: Ian Hickson)
unspecified
All All
: P2 critical
: ---
Assigned To: Paul Cotton
HTML WG Bugzilla archive list
: a11y, a11ytf, a11y_text-alt, TrackerIssue, WGDecision
Depends on: 8171 10455
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-30 13:52 UTC by Gregory J. Rosmaita
Modified: 2013-04-16 15:01 UTC (History)
11 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gregory J. Rosmaita 2010-09-30 13:52:45 UTC
Verbose (As Long As Necessary) Descriptor Requirements

Purpose

The purpose of a verbose descriptor is to describe an image. Such a 
description is essential for users who can not see, but who need 
access to information contained in a graphic. While verbose 
descriptors provide an important accommodation for the blind and 
visually impaired, a verbose descriptor can also be used by those 
with an extremely limited viewport or with cognitive difficulties as 
a guide to navigating and comprehending the described image. This 
means that the exposition of a verbose descriptor must not be an 
"either-or" proposition; rather, the user should be able to control 
the means of exposing the verbose descriptor, including the ability 
to simultaneously view the contents of the image and the contents of 
the verbose description.

Programmatically Determinable

Programmatically determinable [1] relates to the information in web 
content. If technologies that are accessibility supported are used 
properly, then assistive technologies and user agents can access 
the information in the content (i.e., programmatically determine 
the information in the content) and present it to the user. For 
instance longdesc as an attribute should be used as a hook by user 
agents and asssistive technologies in order to notify the user that 
a long description exists, so even if longdesc is applied to an 
image that also serves as a link, it is programmatically possible 
to separate the activation of the longdesc for exposure from the 
UA's universal link activation action (which is usually activated 
with the ENTER key, the SpaceBar, or by mouse click), so that the 
linked image retains the expected behavior in response to user 
interaction while a discrete mechanism is used to retrieve the 
long description.


Issue

Due to the chairs' ruling, on HTML5 ISSUE-30 [2], excluding 
@longdesc, but failing to provide an alternate mechanism to 
provide the functions that had been provided through the 
HTML 4 attribute longdesc [3] there is currently no means of 
providing a programmatically bound verbose (as long as 
necessary) description for an image. Those functions are:

   1. A direct, reusable programmatic determinable mechanism to a 
      long description of an image without a forced visual 
      encumbrance or default visual indicator.

   2. A method to reference a longer description of an image, without 
      including the content in the main flow of a page. 

Many images cannot be sufficiently described with other long description 
techniques. For instance, longdesc currently provides a solution for 
describing the content of images to the blind when it would be:

    * Visually apparent and redundant to a sighted person.
    * Unacceptable to the marketing department due to aesthetic 
      considerations. 

There is currently absolutely no other direct way of doing that without 
a longdesc.


Requirements

   1. A programmatic mechanism to reference a specific set of 
      structured content, internal (enhanced describedby model) 
      or external (HTML4 longdesc model) to the document 
      containing the described image.

   2. A way to inform users and authors that a description is 
      present/available.

   3. A device independent way to access the descriptive content.

   4. An explicit provision that accessing descriptive content, 
      whether internal or external to the document containing 
      the image, does NOT take the user away from the user's 
      position in the document containing the image where the 
      verbose descriptor was invoked;

   5. A way to provide user control over exposition of the 
      descriptor so that rendering of the image and its 
      description is not an either/or proposition. (A visual 
      indicator of the description should NOT be a forced 
      visual encumbrance on sighted users by default).

   6. A method to reference a longer description of an image, 
      without including the content in the main flow of a 
      page. 


Satisfying These Requirements for HTML5

OPTIONS:

   1. retain support for longdesc; allow for exposition of longdesc 
      via user agent preference, context menu, or toggle inline as 
      well as for simultaneous exposition of both the image and its 
      description (useful for those with very limited viewports or 
      users with cognitive issues, who may need a description to 
      guide and to assist in the user's understanding of the image 
      being described);

          * advantage: 2 major browsers already support longdesc 
            natively and are expected to continue to do so as part 
            of their support for HTML4x; 

   2. add support for aria-describedby and deprecate longdesc in HTML5;
 
         * drawback 1: aria-describedby is currently limited to text 
           that appears in the same document as the image being 
           described;

          * drawback 2: The content associated using aria-describedby 
            as currently implemented, is limited to unstructured text; 

   3. add support for external references and structured content to the 
      aria-describedby attribute in HTML5 and deprecate longdesc;

   4. Mint a describedby attribute for the img element (HTML5 Bug 
      10455) [4]

Research

    * [5] Longdesc Examples In the Wild
    * [6] Longdesc Guidelines, Laws, Policy, and Standards 

Related Resources

    * HTML 5 Issue: Image Equivalent Content (HTML WG Wiki page)
    * Chairs' decision on HTML WG Issue-30 (longdesc)
          o cover letter for Chairs' decision on HTML WG Issue 30 (longdesc)
          o HTML WG Issue-30 (longdesc) 

References:

[1] http://www.w3.org/TR/UNDERSTANDING-WCAG20/conformance.html#uc-programmatically-determined-head

[2] http://www.w3.org/html/wg/tracker/issues/30

[3] http://www.w3.org/TR/REC-html40/struct/objects.html#adef-longdesc-IMG

[4] http://www.w3.org/Bugs/Public/show_bug.cgi?id=10455

[5] http://www.d.umn.edu/~lcarlson/research/ld.html#wild

[6] http://www.d.umn.edu/~lcarlson/research/ld.html#glps

[7] http://www.w3.org/html/wg/wiki/LongdescRetention

[8] http://lists.w3.org/Archives/Public/public-html/2010Aug/att-0112/issue-30-decision.html

[9] http://lists.w3.org/Archives/Public/public-html/2010Aug/0112.html

[10] http://lists.w3.org/Archives/Public/public-html/2010Aug/0112.html

[11] http://www.w3.org/html/wg/tracker/issues/30


(the logger of this bug thanks laura carlson and steven faulkner for their
contributions to the wiki page on which this bug report is based
http://www.w3.org/WAI/PF/HTML/wiki/Verbose_desc_reqs)
Comment 1 Ian 'Hixie' Hickson 2010-09-30 18:49:49 UTC
Why is the <p> element not sufficient?

Do you have a concrete page we could use to discuss this showing the problem in question? (It can be an artificially simple page that just has the relevant content, if you like.)
Comment 2 Shelley Powers 2010-09-30 18:58:57 UTC
(In reply to comment #1)
> Why is the <p> element not sufficient?
> 
> Do you have a concrete page we could use to discuss this showing the problem in
> question? (It can be an artificially simple page that just has the relevant
> content, if you like.)

I am sure that Gregory will also respond, but to me the relevant section in his bug report is the following: 

"   2. A method to reference a longer description of an image, without 
      including the content in the main flow of a page. 

I'm assuming the text about being able to provide this in such a way that it's not visible to sighted users is also relevant.

We did not deprecate longdesc, which has a two part aspect to it: discourage use AND provide an equivalent or superior approved technique. All we did is make it obsolete, leaving the functionality it provided unfulfilled. 

However, I think this is a duplicate of another bug? One that Laura filed? The following?

http://www.w3.org/Bugs/Public/show_bug.cgi?id=10455

It got assigned to Paul Cotton, so not sure what's going on.
Comment 3 Ian 'Hixie' Hickson 2010-10-12 06:21:06 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:
   http://dev.w3.org/html5/decision-policy/decision-policy.html

Status: Did Not Understand Request
Change Description: no spec change
Rationale: Gregory, please see comment 1. Thanks.
Comment 4 Sam Ruby 2010-10-12 16:13:24 UTC
Removing TrackerRequest as this is already covered by ISSUE-30.
Comment 5 Martin Kliehm 2010-10-19 15:53:01 UTC
Bug triage sub-team adding TrackerIssue keyword since this is related to ISSUE-30.
Comment 6 Shelley Powers 2010-10-20 15:00:55 UTC
It's inappropriate to remove TrackerRequest because this bug is only incidentally related to the Issue 30 decision.

The Issue 30 decision made longdesc obsolete, but did not provide any alternative method. This bug is about providing an alternative. The editor refuses to do so, therefore it is acceptable to handle this request separate from Issue 30.

I noticed that a TrackerIssue keyword has been added for this item, but it's been tied to Issue 30. Issue 30 is a done deal, it's over and done with. There is a formal objection tied to that decision, but that shouldn't stop work on creating a viable alternative. 

It's important that the HTML WG work consistently, and the effort around this bug has been anything but consistent. It's also important that the co-chairs allow the process they designed to actually work, and for the W3C to honor its own procedural commitments.

I agree on this being a TrackerIssue. I do not agree that this should be associated with a previously decided issue, because this bug is not asking that longdesc be returned, but that something be created to provide the functionality that longdesc provided. The original bug provided very clear and very concise requirements for this replacement.
Comment 7 Sam Ruby 2010-11-30 23:38:09 UTC
This bug is directly related to Issue-30:
http://www.w3.org/html/wg/tracker/issues/30

The HTML WG co-chairs believe that this bug has been addressed by the WG's
decision on ISSUE-30.

/rubys
on behalf of the HTML WG co-chairs
Comment 8 Michael[tm] Smith 2011-12-15 16:39:56 UTC
We discussed this on the a11y TF call, and agree with Sam's assessment that this is covered by issue 30.
Comment 9 Mark Sadecki 2013-04-16 15:01:55 UTC
Given that the longdesc extension is currently a FPWD[1], the TF has decided to close this bug.

[1] http://www.w3.org/TR/html-longdesc/