This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 10543 - Rename a "style sheet blocking scripts" to a "style sheet that is blocking scripts"
Summary: Rename a "style sheet blocking scripts" to a "style sheet that is blocking sc...
Alias: None
Product: HTML WG
Classification: Unclassified
Component: pre-LC1 HTML5 spec (editor: Ian Hickson) (show other bugs)
Version: unspecified
Hardware: All All
: P2 trivial
Target Milestone: ---
Assignee: Ian 'Hixie' Hickson
QA Contact: HTML WG Bugzilla archive list
Depends on:
Reported: 2010-09-03 08:04 UTC by Henri Sivonen
Modified: 2010-10-04 14:45 UTC (History)
4 users (show)

See Also:


Description Henri Sivonen 2010-09-03 08:04:43 UTC
"Style sheet blocking scripts" is confusing, because "style sheet-blocking scripts" would mean the opposite. The distinction is lost if you try to use spec terminology in programming language identifiers like AddStyleSheetBlockingScripts() and, in general, it's good to use spec terminology in implementation.

Please rename "style sheet blocking scripts" to "style sheet that is blocking scripts".

The same concern applies to "foo blocking bar" generally.
Comment 1 Ian 'Hixie' Hickson 2010-09-25 22:01:54 UTC
EDITOR'S RESPONSE: This is an Editor's Response to your comment. If you are satisfied with this response, please change the state of this bug to CLOSED. If you have additional information and would like the editor to reconsider, please reopen this bug. If you would like to escalate the issue to the full HTML Working Group, please add the TrackerRequest keyword to this bug, and suggest title and text for the tracker issue; or you may create a tracker issue yourself, if you are able to do so. For more details, see this document:

Status: Accepted
Change Description: see diff given below
Rationale: Concurred with reporter's comments.
Comment 2 contributor 2010-09-25 22:02:16 UTC
Checked in as WHATWG revision r5503.
Check-in comment: terminology clarification
Comment 3 Ian 'Hixie' Hickson 2010-09-25 22:08:22 UTC
(File new bugs for the other terms if there are any. I wasn't sure how to search for them given how often the term "blocking" appears in the spec.)