This is an archived snapshot of W3C's public bugzilla bug tracker, decommissioned in April 2019. Please see the home page for more details.

Bug 10304 - Rename "remove" method on object store to "delete"
Summary: Rename "remove" method on object store to "delete"
Alias: None
Product: WebAppsWG
Classification: Unclassified
Component: Indexed Database API (show other bugs)
Version: unspecified
Hardware: PC Windows XP
: P2 normal
Target Milestone: ---
Assignee: Nikunj Mehta
QA Contact: public-webapps-bugzilla
Depends on:
Reported: 2010-08-06 12:36 UTC by Kris Zyp
Modified: 2010-10-22 23:07 UTC (History)
4 users (show)

See Also:


Description Kris Zyp 2010-08-06 12:36:58 UTC
Based on the mailing list discussion, it was generally agreed that we could rename the "remove" method on the object store API back to it's original name of "delete". This was originally renamed due to EcmaScript reserved word concern, but since all implementations are targeting EcmaScript 5, and "delete" is contextually unreserved in ES5, the use of "delete" is perfectly fine, and the most clear word for the action of the method.
Comment 1 Jonas Sicking (Not reading bugmail) 2010-10-19 22:16:36 UTC
Checked in a fix.