Evaluation and Repair Tools Working Group Teleconference

20 Apr 2011


See also: IRC log


Shadi, Christophe, Philip, Kostas
Rui, CarlosV



Shadi: Waiting for input from Ed Dumbill re software class in FOAF
... EARL Guide: rename to Developer Guide...; move conformance clauses to this REC doc
... Issues list has been updated (see link in first agendum)
... Many issues now "pending" because we have tentative resoltutions; to be checked by the editors
... Questions?

[HTTP-in-RDF] StatusCode issue

<shadi> http://lists.w3.org/Archives/Public/public-wai-ert/2011Apr/0028.html

Shadi: Also discussed last week; summary sent to mailing list.
... thouights on proposed resoltion?

Kostas: Second proposal to change the statusCodeNumber from "value sent by the server" to "should value"...

Shadi: some people use it to debug servers, so there was a proposal to use statements about how servers respond to certain headers etc
... If we remove it, we will need a very good reason.

<shadi> http://www.w3.org/2006/http#StatusCode

Shadi: Do you have specific concerns with having the "should" value?
... predefined statusCodes are in the spec (cf URL)
... Having the number as part of the predefined statusCode class; currently the number is only inside the header. Issues with this?

Kostas: If we need to "should value" then there is probably no problem.

Shadi: Should have "should" value and value sent by server. Useful for consistency checking
... We have a number of design choices (dc:Identifier; integer datatype...)
... Subproperty of dc:identifier - if we have a use case for this. xml:integer.

Philip: xml:integer is a good idea. Better for tools that process it.
... subproperty of dc:identifier is also a good idea

Christophe: no preference

Shadi: when using an XML datatype: xml preprocessors can have tools to preprocess the data.
... subproperty design: best practice in RDF.
... since we are using a restricted use of dc:identifier, a subproperty would be appropriate

Kostas: subproperty of dc:identifier looks like good idea

Shadi: send this as a suggested resolution to the list to see if anyone has objections.

RESOLUTION: create a subproperty of dc:identifier called statusCodeValue with an xml:integer datatype and with domain statusCode class.

[HTTP-in-RDF] abs_path issue

<shadi> http://lists.w3.org/Archives/Public/public-wai-ert/2011Apr/0029.html

Shadi: basically a naming issue; current name is based on HTTP spec; but other names use camel case.
... matter of preference
... current implementers would need to change their tools, but better now than later

Group: no objects to name change

RESOLUTION: change abs_path property name to absolutePath

[Content-in-RDF] Content Class

<shadi> http://lists.w3.org/Archives/Public/public-wai-ert/2011Apr/0030.html

Shadi: used rdf:about; i.e. byte sequence is something about the object
... suggesion is to use "dct:isFormatOf" and "dc:hasFormat" to express relationships between content representations
... looks like a better model
... Johannes Koch seemed to be in agreement with this proposal
... questions, thoughts, objections?

Philip: Seems to provide better flexibility for later use
... have implemented Content in RDF but this does not seem a major change

Kostas: Accessible tool has not implemented it

<shadi> use "dct:isFormatOf" and "dc:hasFormat" rather than "rdf:about" and

<shadi> "dct:source" to express relationships between content representations

<shadi> and between the original source

RESOLUTION: use "dct:isFormatOf" and "dc:hasFormat" rather than "rdf:about" "dct:source" to express relationships between content representations and between the original source

[EARL Schema] clarify the aspect of casting in example 6

<shadi> http://www.w3.org/TR/2009/WD-EARL10-Schema-20091029/#Assertor

Shadi: Assertor class: example 6: person (Bob) using a tool (Cool Tool) to help makind decision
... the resource described is both a foaf:Agent and a earl:Software at the same time. This is by design.
... If the software were a test subject, it would not be an agent. That is why we did not make earl:Sofware subclass of agent.
... We could add a note to the example explaining the casting aspect and why the code is correct.

Christophe: Would like a small explanation.

Shadi: Comments?
... also refer readers to RDF primer. Some developers are RDF geeks, others aren't.

Philip: About same example: foaf:member is in domain of foaf:group. ... (question)

Shadi: foaf:member has the domain foaf:group, and foaf:group is a subclass of foaf:agent; foaf:agent does not have foaf:member as domain.

<shadi> http://xmlns.com/foaf/spec/#term_Group

Shadi: looks like an issue
... quote: "The Group class represents a collection of individual agents (and may itself play the role of a Agent, something that can perform actions). "
... so example 6 should not be foaf:agent but foaf:group: group of agents working together.

Philip: OK.

RESOLUTION: add a note to the example 6 explaining the casting aspect and why the code is correct
... to change in example 6 the class from foaf:agent to foaf:group.

[EARL Schema] use of URIs, URNs, and other identifiers

Shadi: on test subjects and test criterion classes

<shadi> http://www.w3.org/TR/2009/WD-EARL10-Schema-20091029/#TestSubject

Shadi: see example 7: test subject at http://www.example.org/, which has several parts
... RDF uses URIs to identify resources. In our case, these will be mostly HTTP-based URIs, but it could also be FTP or local
... URNs and isbn (for example) would also be valid.
... the only limitation: things that can have an URI
... if test subject is not in the Internet, file system ... you would not be able of reference it directly

Christophe: example at http://lists.w3.org/Archives/Public/public-wai-ert/2011Apr/0026.html

Shadi: test subject is DAISY book
... any other questions?
... This takes is through all the open issues except Software class and EARL guide rewrite.

Kostas: comments on Pointers in RDF doc?

Misc open comments, if any

<shadi> http://lists.w3.org/Archives/Public/public-wai-ert/2011Apr/0013.html

Kostas: e.g. ptr:byteOffset

<shadi> http://www.w3.org/TR/Pointers-in-RDF10/#terms

<shadi> "char offset" --> "byte offset"

Shadi: see second table in appendix A:

RESOLUTION: at http://www.w3.org/TR/Pointers-in-RDF10/#terms change > "char offset" --> "byte offset" for property ptr:bytOffset

Shadi: Philip taking over editing work from Johannes - for HTTP in RDF and Content in RDF?
... would then be editor's draft that we will look at again.

Upcoming meeting schedule

Shadi: next week: 27 April

Summary of Action Items

[End of minutes]

Minutes formatted by David Booth's scribe.perl version 1.135 (CVS log)
$Date: 2011/04/20 13:35:35 $