[whatwg] [canvas] Path object

I was looking at the canvas Path API and had some concerns. In
particular it's inconsistent with the rest of canvas:

We already have CanvasGradient and CanvasPattern in the global
namespace, so this should probably be called CanvasPath.

We also have createLinearGradient() and createPattern(), but this new
thing is "new Path".

Could we get some consistency here? Like adding new CanvasGradient()
(or a createPath() method) to match up with Path and renaming this
thing CanvasPath?

- Elliott

Received on Sunday, 23 September 2012 04:19:06 UTC