PIL OWL Ontology Meeting 2012-05-21

From Provenance WG Wiki
Revision as of 14:10, 22 May 2012 by Tlebo (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Meeting Information

prov-wg - Modeling Task Force - OWL group telecon

Attendees

  • Tim
  • Daniel
  • Khalid
  • Satya 
  • Stian
  • Stephan
  • Jun
  • Paul

Agenda

For the issues that you are assigned:

  • describe the original concern
  • describe any perspectives already expressed
  • recommend next step, or propose a solution

ISSUES

Daniel

  • seed: ActivityInvolvement subclassOf [ on prov:hadActivity max 0 ] .
    • done: Tim to add to ontology. (and an annotation to the axiom)
    • done (was added): Daniel consider adding the constraint to avoid the "other side"
    • Including replies by stian
> prov:actedOnBehalfOf            prov:responsibleFor. ->+1
> prov:activity                   prov:activityInvolvement ->+0. I suggest "activityInvolvementOf".

no, not "of" - as whatever involvement will be the right hand side. The activity is not an activity-involvement of the involvement.

:assoc1 a prov:Association ;
    prov:activity :a1 .b

:a1 prov:activityInvolvement :assoc1 .


> prov:agent                      prov:agentInvolvement ->+1. I suggest agentInvolvementOf.

Same response as  prov:activityInvolvement .

> prov:alternateOf                prov:alternateOf->+1
> prov:atLocation                 prov:locationOf ->+1
> prov:derivedByInsertionFrom     prov:hadDerivationByInsertion ->+1
> prov:derivedByRemovalFrom       prov:hadDerivationByRemoval->+1
> prov:dictionary                 prov:dictionaryInvolvement ->+1. I suggest to add the "Of" at the end.

Same

> prov:entity                     prov:entityInvolvement ->+1. I suggest to add the "of"

Same.

> prov:generated                  prov:wasGeneratedBy->+1
> prov:hadActivity                prov:wasActivityOfInvolvement. ->+1

> prov:hadGeneration              prov:generatedAsDerivation.

I see you did not vote on this - no wonder as it's a confusing property name! Any better suggestion? Remember it is the inverse pointing back to the prov:Derivation.


:e2 prov:qualifiedDerivation :deriv .
:deriv a prov:Derivation ;
  prov:entity :e1 ;
  prov:hadGeneration :e2Gen .

:e2 prov:qualifiedGeneration :e2Gen .

:e2Gen a prov:Generation ;
  prov:generatedAsDerivation :deriv .




> prov:hadOriginalSource          prov:wasOriginalSourceOf ->+1 (why not just "originalSourceOf")0

To keep it as a verb in past tense.  But perhaps this naming style is not so good in the inverse direction, which is pointing towards the future?


> prov:hadPlan                    prov:wasPlanFor->+1 (Or wasPlanOf)

Yes, wasPlanOf is probably better, as the range will be to some Involvement.


> prov:hadRole                    prov:wasRoleIn ->+1
> prov:hadUsage                   prov:wasUsedInDerivation ->+1. Why not "usedInDerivation"?

This is the equivalent of prov:generatedAsDerivation above. I think I added 'was' to clarify the direction - the Usage did not "use". However you can argue the Generation did not "generate" either - so they 


:e2 prov:qualifiedDerivation :deriv .
:deriv a prov:Derivation ;
  prov:entity :e1 ;
  prov:hadUsage :e1Usage .

:e1Usage a prov:Usage ;
  prov:entity :e1 ;
  prov:wasUsedInDerivation :deriv .


It is also a bit strange as to me it reads like :deriv is a prov:Activity rather than just some details about the derivation.  But the real activity is just implied here.

> prov:hasAnnotation              prov:annotates. ->+1(This is getting removed) > prov:inserted                   prov:wasInsertedBy. ->+1 > prov:involved                   prov:wasInvolvedWith ->+1 > prov:involvee                   prov:involvement ->+1 > prov:member                     prov:inMembership ->+1. > prov:membership                 prov:membershipOf->+1 > prov:qualifiedAssociation       prov:associatedActivity ->+1 > prov:qualifiedAttribution       prov:attributedEntity ->+0. I suggest to rename it quoalifiedAttributionOf. > prov:qualifiedCommunication     prov:informedActivity->-1. It is very similar to wasInformedBy. I think that something like "qualifiedCommunicationOf" is better > prov:qualifiedDerivation        prov:derivedEntity ->+0. I prefer qualifiedDerivationOf > prov:qualifiedEnd               prov:endedActivity->+0. I pr efer quoalifiedEndOf > prov:qualifiedGeneration        prov:generatedEntity->+0. I suggest qualifiedGenerationOf. "generated" and "generatedEntity" could lead to confussion. > prov:qualifiedInsertion         prov:insertedToDictionary ->+1 > prov:qualifiedQuotation         prov:quotedByEntity ->-1. It could be confused with wasQuotedBy. I suggest to rename it qualifiedQuotationOf. > prov:qualifiedRemoval           prov:removedFromDictionary -> rename it to qualifiedRemovalOf > prov:qualifiedResponsibility    prov:responsibleAgent. ->+0 I suggest qualifiedResponsabilityOf > prov:qualifiedRevision          prov:revisedEntity ->+1 I suggestqualifiedRevisionOf (to keep the same pattern) > prov:qualifiedSource            prov:sourcingEntity ->+0 I suggest qualifiedSourceOf > prov:qualifiedStartByActivity   prov:activityStartedActivity-> this is being dropped. > prov:qualifiedStart             prov:startedActivity ->+0. I prefer qualifiedStartOf. It can be confused with "wasStartedBy" > prov:qualifiedTrace             prov:tracedEntity ->+0. I suggest qualifiedTraceOf > prov:qualifiedUsage             prov:consumingActivity ->+0. I suggest cualifiedUsageOf

I have no hard feelings about any of these. I removed the "qualified" prefix so that it would somewhat match up with the outgoing prov:activity/prov:entity/.... This will effectively point to the subject of the reified triple. I agree we should be consistent with the pattern.  (My pattern was prov:.*(Activity|Entity|Agent) )

Just remember the direction. It will be for instance:

e2 prov:wasDerivedFrom :e1 ;

    prov:qualifiedDeriation :e2Deriv .

e2Deriv a prov:Derivation ; 

    prov:entity :e1 ;     prov:derivedEntity :e2 .


So "qualifiedDerivationOf" would read wrong to me - because it is :e1 we derive from, not :e2. I also struggled in that these need to be specific per involvement type to be proper inverses of the specific qualified*, so you can't say have a general prov:qualifyingEntity.


> prov:specializationOf           prov:generalizationOf ->+1 > prov:tracedTo                   prov:tracedFrom ->+1 > prov:used                       prov:wasUsedBy ->+1 > prov:value                      prov:valueOf ->+1 > prov:wasAssociatedWith          prov:wasAssociateFor ->+1 > prov:wasAttributedTo            prov:contributed ->+1 > prov:wasDerivedFrom             prov:hadDerivation. ->+1 > prov:wasEndedBy                 prov:ended ->+1 > prov:wasGeneratedBy             prov:generated ->+1 > prov:wasInformedBy              prov:informed. ->+1 > prov:wasInvalidatedBy           prov:invalidated->+1 > prov:wasQuotedFrom              prov:wasQuotedBy ->+0. Other relationships using "By" denote agency. I suggest to rename it wasQuotedIn.

Oh no, this is a sensitive one for us two! The range of the inverse will be the quote entity (the paragraph), so you can't say "bible quoted in" - there is nothing more to be inside.

What about prov:quotedAs  ?  


> prov:wasRevisionOf              prov:hadRevision ->+1 > prov:wasStartedByActivity       prov:activityStarted ->+0. This is being removed. > prov:wasStartedBy               prov:started ->+1

Stian

  • https://www.w3.org/2011/prov/track/issues/372 qualified prop chains
    • (prov:qualifiedUsage prov:entity) rdfs:subPropertyOf prov:used .
    • Why the new "RL++ errors"?  
    • Jun/Stian/Satya will take a look and report back what that error message means so that we can include them in the HMTL page (send emails to 372 chain)
    • Satya: playing with protege OWL API. Trying to recreate the error.
    • ... Stian sent a summary.
    • ... shouldn't be a problem
    • Stian: thinks a bug in the OWL API.
    • Jun: tried to reproduce the error, but it never worked (never got anything back).
  • https://www.w3.org/2011/prov/track/issues/374 prov:membership [ a prov:Membership ]
    •   TIm: why do we have the indirection?
    • TODO: Stian to think it through and reply on the list.
    • Khalid: b/c it was incomplete.
    • Stian: "complete membership" we have CompleteMembership.
  • https://www.w3.org/2011/prov/track/issues/322
    • can be Closed? 
    • atributes of prov:Start will not apply to prov:Association (since prov:Start is subclass of EntityInvolvement, while prov:Association is subclass of AgentInvolvement)

Satya

  • For Involvement example - use non PROV properties (not use specific sub-type of involvement)
  • https://www.w3.org/2011/prov/track/issues/288
    • Activity is still not optional for Usage (it is for Generation)
    • Satya: binary rlation should have two required parameters
    • ... In Genarted, Activity is optional.
    • ... In Usage, it is NOT.
    • TODO: assign to DM.




CLOSED by Luc/James ISSUE-213 (https://www.w3.org/2011/prov/track/issues/213)


CLOSED by Luc ISSUE-253 (https://www.w3.org/2011/prov/track/issues/253) (seems to be) Closed


Moved to Best Practices. ISSUE-296 (https://www.w3.org/2011/prov/track/issues/296) SpatialThing not part of DM/O. Can be closed?


POSTPONDED ISSUE-284 (https://www.w3.org/2011/prov/track/issues/284) Not resolved, but can be closed for now

POSTPONDED ISSUE-289 (https://www.w3.org/2011/prov/track/issues/289) Not resolved, but can be closed for now

CLOSED ISSUE -306 (https://www.w3.org/2011/prov/track/issues/306) Closed

CLOSED ISSUE-275 (https://www.w3.org/2011/prov/track/issues/275) Closed (bundles not part of DM)

CLOSED ISSUE-290 (https://www.w3.org/2011/prov/track/issues/290) Resolved? (could not find "Starting" in DM)

CLOSED ISSUE-291 (https://www.w3.org/2011/prov/track/issues/291) Resolved (Closed?)

CLOSED ISSUE-292 (https://www.w3.org/2011/prov/track/issues/292) (Closed?) ActivityInvolvement disjoint with EntityInvolvement

CLOSED ISSUE-293 (https://www.w3.org/2011/prov/track/issues/293) Can be closed

CLOSED ISSUE-294 (https://www.w3.org/2011/prov/track/issues/294) Not sure what the issue is (related to signature of Derivation), can be closed ?

CLOSED ISSUE-297 (https://www.w3.org/2011/prov/track/issues/297) can be Closed? (wascheduledafter not part of DM) voting on email thread "provenance of provenance", http://lists.w3.org/Archives/Public/public-prov-wg/2012May/0162.html)


CLOSED ISSUE-300 (https://www.w3.org/2011/prov/track/issues/300) Resolved (Closed?) Quotation is subclass of EntityInvolvement which is disjoint from ActivityInvolvement There is no class called "Quote"

CLOSED ISSUE-301 (https://www.w3.org/2011/prov/track/issues/301) Closed? (Collections being addressed separately)

CLOSED ISSUE-310 (https://www.w3.org/2011/prov/track/issues/310) Closed?

CLOSED ISSUE-356 (https://www.w3.org/2011/prov/track/issues/356) Open needs to be resolved

CLOSED ISSUE-283 (https://www.w3.org/2011/prov/track/issues/283) Note and Location are still not subclass of Entity.

Tim

... people have been saying there there is "systematic patterns" for qualifcations.

Stephan

Khalid


Is this justified by annotations?:

CLOSED (after meeting) ISSUE-299 (https://www.w3.org/2011/prov/track/issues/299) wasAttributedTo is subproperty of tracedTo prov:Attribution is subclass of AgentInvolvement, prov:Trace subclass of EntityInvolvement

Jun

Stian:  I think Ivan's link to owl2-syntax should be OK, at least it has  headers like "Functional" as compared to the primer where you might get  lost following the link. There's no way we can force the Turtle to be  displayed by default, but there is a "Show RDF" button on the top of the page. Nice catch, Stian! 


AOB

How would you encode http://aquarius.tw.rpi.edu/prov-wg/prov-o#acknowledgements in prov-o?