W3C

But I hear 2.0 is not backwards compatible


How could you accept that?

Interoperability with XQuery